Issues affecting email access

Major incident Your Services Email Services
2022-05-26 14:19 UTC · 3 hours, 1 minute

Updates

Resolved

This is resolved, thank you so much for your patience!

May 26, 2022 · 17:21 UTC
Issue

Some customers may be seeing issues accessing their emails at the moment. We’re really sorry for the inconvenience, and are working to get things back to normal ASAP!

May 26, 2022 · 14:20 UTC

← Back