Connectivity issues

Major incident Your Services Email Services Linux Hosting Platform WordPress Hosting Platform Lyrical CP Lyrical Host Lyrical Host Hub
2022-02-28 18:49 UTC · 58 minutes

Updates

Resolved

Thank you so much for your patience; we’re continuing to monitor the situation as required :)

February 28, 2022 · 19:48 UTC
Issue

Some customers may currently be seeing connectivity issues trying to access sites and other services. Please rest assured that we’re working on the problem to fix it as soon as humanly possible!

February 28, 2022 · 18:59 UTC

← Back