Service slowness and errors

Major incident Your Services Linux Hosting Platform WordPress Hosting Platform
2021-09-14 15:50 UTC · 4 hours

Updates

Resolved

Thank you for your patience :)

November 4, 2021 · 15:25 UTC
Issue

Some customers may be experiencing slower than normal websites, and forbidden or 503 errors. We’re really sorry for the inconvenience, and we’re working really hard to get everything back to normal.

November 4, 2021 · 15:25 UTC

← Back