Ticket responses

Major incident Lyrical Host Lyrical Host Hub
2021-07-11 01:38 UTC · 1 day, 12 hours, 31 minutes

Updates

Resolved

All resolved, thanks for your patience :)

November 4, 2021 · 15:25 UTC
Issue

Please note that we will be responding to your tickets via email while a bug is fixed with our CRM. If your ticket isn’t important, please consider opening it on Monday instead. We’re really sorry for the inconvenience, and appreciate your patience!

November 4, 2021 · 15:25 UTC

← Back