Network connectivity issues

Major incident Your Services Email Services Linux Hosting Platform WordPress Hosting Platform Lyrical CP Lyrical Host Lyrical Host Hub
2021-03-15 15:21 UTC · 16 minutes

Updates

Resolved

Sites should now be operating as normal, thanks for your patience!

November 4, 2021 · 15:25 UTC
Investigating

Sites may be running slower than normal; we hope to have everything up to speed shortly!

November 4, 2021 · 15:25 UTC
Issue

We’re currently investigating some network connectivity issues affecting some customers. We’re really sorry for the inconvenience, and we’ll report back here with more information. Thanks for your patience!

November 4, 2021 · 15:25 UTC

← Back