Website connectivity

Minor incident Your Services WordPress Hosting Platform
2026-07-09 10:32 UTC · 2 hours, 3 minutes

Updates

Resolved

This has now been fixed; thank you for your patience!

July 9, 2026 · 12:35 UTC
Issue

A small minority of customers may be seeing downtime for their websites as we are in the process of replacing a faulty hardware component. Please sit tight and thank you for your patience as we carry out this unanticipated work.

July 9, 2026 · 10:32 UTC

← Back