Google Email Outage

Major incident Your Services Email Services
2020-12-15 22:59 UTC · 11 hours, 50 minutes

Updates

Resolved

:)

November 4, 2021 · 15:24 UTC
Issue

Some Gmail users may be having trouble receiving email right now and many emails to Gmail users are bouncing. Google is aware of the issue and is currently working on fix, so please sit tight! Thanks so much for your patience :)

November 4, 2021 · 15:24 UTC

← Back