Google Email Outage

Major incident Your Services Email Services
2020-12-14 12:28 UTC · 2 hours, 43 minutes

Updates

Resolved

:)

November 4, 2021 · 15:24 UTC
Issue

Due to a current Google outage, customers trying to send or receive emails via Google or Gmail services may currently be experiencing issues. We’re waiting on Google to resolve it, so please sit tight! Thanks so much for your patience :)

November 4, 2021 · 15:24 UTC

← Back