DNS Issues

Major incident Your Services Linux Hosting Platform WordPress Hosting Platform Lyrical CP
2020-10-25 12:23 UTC · 37 minutes

Updates

Resolved

This issue has now been resolved - thanks so much for sticking with us!

November 4, 2021 · 15:24 UTC
Issue

Some customers may be experiencing difficulties with site access. We’re currently investigating the issue and hope to have it resolved shortly. Thanks so much for your patience!

November 4, 2021 · 15:24 UTC

← Back