White screens

Major incident Your Services WordPress Hosting Platform
2020-09-17 13:50 UTC · 1 hour, 17 minutes

Updates

Resolved

This is now resolved, thank you for your patience!

November 4, 2021 · 15:24 UTC
Issue

Some customers may be experiencing a white screen when visiting their site or logging into their admin Dashboard. Please sit tight while we investigate further, and we hope to have this resolved very soon!

November 4, 2021 · 15:24 UTC

← Back