Connectivity issues

Minor incident Your Services Linux Hosting Platform WordPress Hosting Platform
2025-06-05 16:06 UTC · 13 minutes

Updates

Resolved

This is now resolved, thank you for your patience!

June 5, 2025 · 16:19 UTC
Issue

We’re currently investigating intermittent connectivity issues affecting Germany and parts of Eastern Europe. Please sit tight while we fix the issue - thank you for your patience!

June 5, 2025 · 16:06 UTC

← Back