Email sending issues

Minor incident Your Services Email Services
2025-01-10 13:51 UTC · 3 hours, 30 minutes

Updates

Resolved

This is now resolved. Thank you for your patience!

January 10, 2025 · 17:21 UTC
Issue

Due to a performance upgrade, customers may be seeing temporary issues sending emails. Please sit tight while we fix this unexpected issue. Thanks for your patience!

January 10, 2025 · 13:51 UTC

← Back