Connectivity issues affecting some websites

Major incident Your Services Email Services Linux Hosting Platform WordPress Hosting Platform Lyrical CP Lyrical Host Lyrical Host Hub
2024-11-29 13:52 UTC · 26 minutes

Updates

Resolved

This is now resolved, thank you for your patience!

November 29, 2024 · 14:19 UTC
Issue

Some customers may be experiencing intermittent issues visiting websites. Please sit tight while we resolve this ASAP! Thanks for your patience.

November 29, 2024 · 13:52 UTC

← Back