Database update

Minor incident Lyrical Host Lyrical Host Hub
2024-11-29 12:48 UTC · 55 minutes

Updates

Resolved

This is now complete, thank you for your patience!

November 29, 2024 · 13:44 UTC
Issue

We are currently making an essential database update which we expect to be completed soon. During this time, our website will be temporarily inaccessible. Thanks for your patience!

November 29, 2024 · 12:48 UTC

← Back