European connection issues

Minor incident Your Services Email Services Linux Hosting Platform WordPress Hosting Platform Lyrical CP Lyrical Host Lyrical Host Hub
2024-10-23 09:49 UTC · 1 hour, 58 minutes

Updates

Resolved

This is now resolved. Thank you for your patience!

October 23, 2024 · 11:47 UTC
Issue

Customers in or near the south east of Europe may currently be seeing difficulties accessing sites and services. Please sit tight as we resolve this ASAP!

October 23, 2024 · 09:49 UTC

← Back