Slow and inaccessible websites
Major incident
Your Services
Email Services
Linux Hosting Platform
WordPress Hosting Platform
Lyrical CP
Lyrical Host
Lyrical Host Hub
2024-03-28 15:51 UTC
· 1 hour, 44 minutes
Updates
Monitoring
March 28, 2024 · 16:17 UTC
Your website should be back online shortly if it’s not already back. Thanks so much for your patience!
Investigating
March 28, 2024 · 16:06 UTC
The issue has been identified and fixing has begun - thanks for your patience! We’ll update here with more information.
Issue
March 28, 2024 · 15:51 UTC
Customers may be seeing issues trying to access services and websites currently. Please sit tight while we investigate further and resolve the issue ASAP! Thanks so much for your patience!
← Back