Inaccessible websites

Major incident Your Services Email Services Linux Hosting Platform WordPress Hosting Platform Lyrical CP Lyrical Host Lyrical Host Hub
2024-02-05 09:47 UTC · 55 minutes

Updates

Resolved

Thank you for your patience while we resolved this issue; you can find out more on our blog: https://www.lyricalhost.com/blog/what-is-a-ddos-attack-why-do-they-happen/

February 5, 2024 · 10:42 UTC
Monitoring

The majority of websites affected are accessible again and the cause has been identified as a DDoS attack. You can find out more here: https://www.lyricalhost.com/blog/what-is-a-ddos-attack-why-do-they-happen/

February 5, 2024 · 10:19 UTC
Issue

Some customers may be unable to access their websites or services currently; please sit tight as we investigate and resolve the issue. Thanks so much for your patience!

February 5, 2024 · 09:47 UTC

← Back