Timeline backups

Minor incident Your Services Lyrical CP
2023-10-12 21:27 UTC · 11 hours, 26 minutes

Updates

Resolved

This has now been resolved, thank you for your patience!

October 13, 2023 · 08:53 UTC
Issue

Timeline backups are currently unavailable due to a fibre connection issue. If you have any questions about this or backing up your website, please raise a support ticket at hub.lyricalhost.com. Thank you for your patience while we resolve this!

October 12, 2023 · 21:27 UTC

← Back