Connectivity issues

Major incident Your Services Email Services Linux Hosting Platform WordPress Hosting Platform Lyrical CP Lyrical Host Lyrical Host Hub
2023-09-27 21:19 UTC · 1 hour, 26 minutes

Updates

Resolved

Thank you for your patience, the issue has been resolved and we’re continuing to monitor.

September 27, 2023 · 22:44 UTC
Issue

Some customers may currently be experiencing difficulty accessing their sites and services. Please note this a location-based routing issue and only affects a minority of websites, but we’re investigating as a top priority. We’re really sorry for the inconvenience and thank you for your patience!

September 27, 2023 · 21:19 UTC

← Back