Connectivity issues

Major incident Your Services Email Services Linux Hosting Platform WordPress Hosting Platform Lyrical CP Lyrical Host Lyrical Host Hub
2023-08-12 13:17 UTC · 3 hours, 36 minutes

Updates

Resolved

This issue has been resolved, thank you for your patience!

August 12, 2023 · 16:51 UTC
Issue

A few customers have reported intermittent difficulties accessing sites and services. This is a location-dependent issue and the vast majority of people globally will still be able to access your website. We’re really sorry for the inconvenience - please sit tight while we investigate further and resolve the issue. Thank you for your patience!

August 12, 2023 · 13:17 UTC

← Back