Intermittent issues

Major incident Lyrical Host Lyrical Host Hub
2023-03-13 15:48 UTC · 7 hours, 17 minutes

Updates

Resolved

This is resolved, thanks for your patience!

March 13, 2023 · 23:06 UTC
Issue

Some customers may currently be experiencing issues raising support tickets, seeing replies to support tickets, or seeing cached information in the Hub. Please bear with us while we investigate further with a view to getting this resolved as soon as possible. If you have an urgent support issue, please private message us at facebook.com/lyricalhost, instagram.com/lyricalhost or twitter.com/lyricalhost

March 13, 2023 · 15:51 UTC

← Back