Connectivity issues

Major incident Your Services Email Services Linux Hosting Platform WordPress Hosting Platform Lyrical CP Lyrical Host Lyrical Host Hub
2022-12-01 17:53 UTC · 1 hour, 18 minutes

Updates

Resolved

Thank you for your patience!

December 1, 2022 · 19:12 UTC
Monitoring

We’re seeing services operating as normal now, and we’re monitoring the situation. Thanks so much for your patience, and apologies for the inconvenience caused.

December 1, 2022 · 18:17 UTC
Issue

Some customers may be experiencing connectivity issues when trying to access websites. Please bear with us while we fix it ASAP!

December 1, 2022 · 17:54 UTC

← Back